Skip to main content

فرض کنید که در مدیریت بسته های PHP توسط سرور خود دچار مشکل شده اید یا از نسخه وردپرسی استفاده می کنید که نیاز به ارتقا ورژن PHP دارد. در این صورت باید بلد باشید که چگونه این کار را انجام دهید؛ چرا که به روزرسانی و تغییر نسخه PHP برای امنیت وب سایت شما حیاتی است. آخرین به روزرسانی های امنیتی، همراه با نسخه جدید PHP ارائه می شوند. در این مقاله قرار است تغییر نسخه PHP در سی پنل را به شما آموزش دهیم.

چگونه نسخه PHP را در سایت ارتقا دهیم؟

اگر وب سایت شما به تغییر نسخه PHP نیاز دارد، پس در ابتدا باید وارد سی پنل خود شوید تا به مدیریت ورژن های PHP دسترسی داشته باشید.

نکته مهم:

در زمین هاست، تمام تلاش تیم پشتیبانی بر این است تا نسخه PHP شما به روز باشد. اگر زمانی نیاز به تغییر در نسخه PHP خود داشتید، می توانید با تیم پشتیبانی ما تماس بگیرید، تا این کار به راحتی و در کمترین زمان ممکن برای شما انجام شود.

تغییر نسخه PHP با MultiPHP Manager یا PHP Selector

بسته به نسخه cPanel که استفاده می کنید، می توانید از MultiPHP Manager یا PHP Selector برای تغییر نسخه PHP خود استفاده کنید. PHP Selector در حال حذف شدن است، بنابراین به احتمال زیاد باید از MultiPHP Manager استفاده کنید.

تغییر نسخه PHP در سی پنل با استفاده از MultiPHP Manager:

برای تغییر نسخه سی پنل با استفاده از MultiPHP Manager، مراحل زیر را طی کنید:

  • وارد داشبورد کنترل پنل سی پنل خود شوید.
  • به قسمت Software بروید و گزینه MultiPHP Manager را انتخاب کنید.
وارد داشبود سی پنل خود شده و در قسمت Software گزینه MultiPHP Manager را انتخاب کنید.
  • با علامت زدن کادر سمت چپ، دامنه ای که می خواهید نسخه PHP آن را ارتقا دهید را انتخاب کنید.
دامنه ای که می خواهید نسخه PHP آن را ارتقا دهید را انتخاب کنید.
  • جدیدترین نسخه PHP را از منوی کشویی انتخاب کنید، سپس روی گزینه Apply کلیک کنید.
نسخه پی اچ پی مد نظرتان را انتخاب کرده و تایید کنید.
  • یک پاپ آپ در گوشه سمت راست بالا ظاهر می شود و به شما اطلاع می دهد که تغییر موفقیت آمیز بوده است.

اگر قبلا از PHP Selector برای تغییر نسخه PHP خود استفاده کرده اید، احتمالا یک کنترل کننده در فایل .htaccess شما وجود داشته باشد؛ مانند نمونه زیر که باید حذف شود:

Use PHPedge as default
AddHandler application/x-httpd-php-edge .php
<IfModule mod_suphp.c>
    suPHP_ConfigPath /opt/phpedge/lib
</IfModule>

تغییر نسخه PHP در سی پنل با استفاده از PHP Selector:

PHP Selector در برخی از سرورهای اشتراکی قرار دارد. هر چند در آینده ای نه چندان دور این گزینه از سی پنل حذف خواهد شد. اما اگر هنوز به این گزینه دسترسی دارید، برای تغییر نسخه PHP بهتر است روش زیر را دنبال کنید:

  • وارد داشبورد سی پنل شوید.
  • در قسمت Software بر روی PHP Selector کلیک کنید.
  • به دایرکتوری وب سایت (جایی که در آن می توانید نسخه PHP خود را تغییر دهید) بروید. فایل اصلی در فولدر public_html قرار دارد.
  • نسخه PHP مورد نظر خود را از منوی کشویی انتخاب کنید، سپس روی upgrade کلیک کنید.
نسخه PHP مورد نظر خود را از منوی کشویی انتخاب کنید، سپس روی upgrade کلیک کنید.

نکته مهم:

اگر اسکریپت های سایت شما به توابع قدیمی تر PHP متکی هستند و این توابع در نسخه های به روزتر دیگر موجود نیستند، به احتمال زیاد در هنگام به روزرسانی نسخه PHP خود با مشکل مواجه خواهید شد.